MySQL error when browsing to index.php

Announcements, promotions, news, help. Ask about registrations, avatars, PM and others. Post all your forum and Singapore Expats site related questions here.
Post Reply
User avatar
zzm9980
Governor
Governor
Posts: 6869
Joined: Wed, 06 Jul 2011 1:35 pm
Location: Once more unto the breach

MySQL error when browsing to index.php

Post by zzm9980 » Wed, 10 Apr 2013 5:21 pm

http://forum.singaporeexpats.com/index.php

Code: Select all

Warning: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in /home/singap2/public_html/forum/db/mysql4.php on line 48

Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in /home/singap2/public_html/forum/db/mysql4.php on line 330

Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in /home/singap2/public_html/forum/db/mysql4.php on line 331
phpBB : Critical Error 

Could not connect to the database
Removing the index.php part of the URL allows the site to load just fine (obviously since I'm here posting this), but some of the links on the forums send you back to that index.php. For example, clicking "Singapore Expats Forum ->", the parent to the left of the name of the current sub-forum.

User avatar
sundaymorningstaple
Moderator
Moderator
Posts: 39770
Joined: Thu, 11 Nov 2004 1:26 pm
Answers: 10
Location: Retired on the Little Red Dot

Post by sundaymorningstaple » Wed, 10 Apr 2013 6:04 pm

Happens occasionally to me as well, but it's seems it's a time out type of affair as I'm able to click the parent link and go to the index page with no problem (at the moment). But I do have it happen occasionally.
SOME PEOPLE TRY TO TURN BACK THEIR ODOMETERS. NOT ME. I WANT PEOPLE TO KNOW WHY I LOOK THIS WAY. I'VE TRAVELED A LONG WAY, AND SOME OF THE ROADS WEREN'T PAVED. ~ Will Rogers

User avatar
zzm9980
Governor
Governor
Posts: 6869
Joined: Wed, 06 Jul 2011 1:35 pm
Location: Once more unto the breach

Post by zzm9980 » Wed, 10 Apr 2013 7:42 pm

sundaymorningstaple wrote:Happens occasionally to me as well, but it's seems it's a time out type of affair as I'm able to click the parent link and go to the index page with no problem (at the moment). But I do have it happen occasionally.
This was most of the day for me. Since I book marked the /index.php, I had to manually erase it every time I opened the page.

My guess is if the website is sitting behind a load balancer, one of the systems behind it had an issue (Since a load balancer will generally keep sending the same clients to the same systems for a while)

Pal
Site Admin
Site Admin
Posts: 1412
Joined: Wed, 23 Jul 2003 2:44 am
Location: Singapore
Contact:

Post by Pal » Sun, 14 Apr 2013 2:21 am

MYSQL was down for a while and the error page is in your cache.

Refresh / reload your browser if you encounter it again.
Singapore Expats

Home | Classifieds | Condo | Forum | Property
Image

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “Announcement, Help & FAQ”

Who is online

Users browsing this forum: No registered users and 0 guests