Singapore Expats Forum

admin: Filtering unicode output 中文

Announcements, promotions, news, help. Ask about registrations, avatars, PM and others. Post all your forum and Singapore Expats site related questions here.
User avatar
zzm9980
Governor
Governor
Posts: 6842
Joined: Wed, 06 Jul 2011
Location: Once more unto the breach

admin: Filtering unicode output 中文

Postby zzm9980 » Wed, 29 Jan 2014 9:19 pm

Hi Admin,

As someone who knows web application security in and out, I could understand why you may be inclined to filter non-ASCII output and render it as a ? instead. But really, on a forum targeting expats in a Chinese speaking country, you should allow at least the simplified Chinese character set.

Thanks :)

Pal
Site Admin
Site Admin
Posts: 1203
Joined: Wed, 23 Jul 2003
Location: Singapore
Contact:

Testing一二三

Postby Pal » Wed, 29 Jan 2014 10:12 pm

新加å
Last edited by Pal on Thu, 30 Jan 2014 1:05 am, edited 1 time in total.
Singapore Expats

Home | Classifieds | Condo | Forum | Property
Image

Pal
Site Admin
Site Admin
Posts: 1203
Joined: Wed, 23 Jul 2003
Location: Singapore
Contact:

Re: admin: Filtering unicode output

Postby Pal » Thu, 30 Jan 2014 1:05 am

zzm9980 wrote:Hi Admin,

As someone who knows web application security in and out, I could understand why you may be inclined to filter non-ASCII output and render it as a ? instead. But really, on a forum targeting expats in a Chinese speaking country, you should allow at least the simplified Chinese character set.

Thanks :)


Added the UTF8 input, please inform me if anyone encounter any problem.

Thanks! 谢谢!
Singapore Expats



Home | Classifieds | Condo | Forum | Property

Image

User avatar
sundaymorningstaple
Moderator
Moderator
Posts: 35159
Joined: Thu, 11 Nov 2004
Location: Still Fishing!
Contact:

Postby sundaymorningstaple » Thu, 30 Jan 2014 6:52 am

I no longer see ??? but actual characters now.

Pal
Site Admin
Site Admin
Posts: 1203
Joined: Wed, 23 Jul 2003
Location: Singapore
Contact:

Postby Pal » Thu, 30 Jan 2014 8:08 am

SMS, throughout the years, when type in Chinese it shows ??? ?

Can someone also try other languages now? Like Japanese, etc ....
Singapore Expats



Home | Classifieds | Condo | Forum | Property

Image

User avatar
Saint
Director
Director
Posts: 3535
Joined: Thu, 16 Jun 2005
Location: The Juban Stand, Boat Quay
Contact:

Postby Saint » Thu, 30 Jan 2014 9:16 am

The common language quite widely used in this forum known as "Talking completed and utter bollox" is still working well and can clearly been seen regularly.

I hope that helps

User avatar
Sergei82
Editor
Editor
Posts: 1455
Joined: Mon, 02 Nov 2009

Postby Sergei82 » Thu, 30 Jan 2014 10:10 am

Testing mine... :?

раз два три четыре пÑ

Pal
Site Admin
Site Admin
Posts: 1203
Joined: Wed, 23 Jul 2003
Location: Singapore
Contact:

Postby Pal » Thu, 30 Jan 2014 11:09 am

[quote="Sergei82"]Testing mine... :?

раз два три четыре пÑ
Singapore Expats



Home | Classifieds | Condo | Forum | Property

Image

User avatar
sundaymorningstaple
Moderator
Moderator
Posts: 35159
Joined: Thu, 11 Nov 2004
Location: Still Fishing!
Contact:

Postby sundaymorningstaple » Thu, 30 Jan 2014 11:17 am

Seems to be working okay for mine. I've seen Chinese characters on here before with no problem though. In fact, I've seen some of ZZM's responses on here in Chinese. Not sure why he's having a problem now.

Pal
Site Admin
Site Admin
Posts: 1203
Joined: Wed, 23 Jul 2003
Location: Singapore
Contact:

Postby Pal » Thu, 30 Jan 2014 11:29 am

sundaymorningstaple wrote:Seems to be working okay for mine. I've seen Chinese characters on here before with no problem though. In fact, I've seen some of ZZM's responses on here in Chinese. Not sure why he's having a problem now.


Ya, I thought I seen some Chinese characters in the past.
Singapore Expats



Home | Classifieds | Condo | Forum | Property

Image

User avatar
zzm9980
Governor
Governor
Posts: 6842
Joined: Wed, 06 Jul 2011
Location: Once more unto the breach

Postby zzm9980 » Thu, 30 Jan 2014 12:05 pm

Pal wrote:
sundaymorningstaple wrote:Seems to be working okay for mine. I've seen Chinese characters on here before with no problem though. In fact, I've seen some of ZZM's responses on here in Chinese. Not sure why he's having a problem now.


Ya, I thought I seen some Chinese characters in the past.


Yes it stopped working recently, in the past few months. Looks good now though.

我现在看汉字

User avatar
JR8
Immortal
Immortal
Posts: 16514
Joined: Wed, 24 Mar 2010
Location: K. Puki Manis

Postby JR8 » Thu, 30 Jan 2014 1:22 pm

But... I thought one of the ground-rules was people had to post in English. Otherwise how can the forum be moderated?

User avatar
sundaymorningstaple
Moderator
Moderator
Posts: 35159
Joined: Thu, 11 Nov 2004
Location: Still Fishing!
Contact:

Postby sundaymorningstaple » Thu, 30 Jan 2014 1:29 pm

It's not a case of people posting thread in other languages, but like zzm usually does, is a case of using the language to fine tune what is trying to be said in English as often there is not a direct accurate translation and only Chinese can convey the nuances. I reckon it is sometimes the same. We do, however, recommend that all post using English as it is an English based board. I see it like emoticons. It often adds the nuance than the English written word often cannot. (unless you are Shakespeare).

User avatar
sundaymorningstaple
Moderator
Moderator
Posts: 35159
Joined: Thu, 11 Nov 2004
Location: Still Fishing!
Contact:

Postby sundaymorningstaple » Thu, 30 Jan 2014 1:35 pm

I often use an on-line translator to get a drift of what is said, but with limited success.

User avatar
sundaymorningstaple
Moderator
Moderator
Posts: 35159
Joined: Thu, 11 Nov 2004
Location: Still Fishing!
Contact:

Postby sundaymorningstaple » Thu, 30 Jan 2014 1:35 pm

zzm9980 wrote:
我现在看汉字


Yep. Me too.


  • Similar Topics
    Replies
    Views
    Last post

Return to “Announcement, Help & FAQ”

Who is online

Users browsing this forum: No registered users and 0 guests